How To Solve core-js dependency is deprecated – cannot build package

Share This Post

Are You Getting I’m getting npm WARN deprecated [email protected]: [email protected]<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of [email protected] Error while creating a new Angular application. Here Our Team is Given All Possible Solution For This Error. Please Comment If You Having Any Query. Please Comment below if Your Error Resolved.

Solution 1

It’s a npm cache problem. Go to the path

C:\Users\johndoe\AppData\Roaming\npm-cache

and delete its content. Then open your console in administrator mode and execute the npm install command again

Solution 2

Indeed the issue was with cache . Try To Install this By excutute This Command npm clean-install.

This Is Worked For Me As Well

Solution 3

You should update the version of core-js to version above 3.  npm install --save [email protected]^3

You may also update the outdated packages using  npm update [-g] [<pkg>...]

Solution 4

Observed this warning message within a Vaadin project with Vaadin 14.1.3 after switching from dependency com.vaadin.vaadin to com.vaadin.vaadin-core. The warning was gone after these steps:

  1. delete package-lock.json
  2. execute mvn clean
  3. execute mvn update

So above four Solution May help You. Comment Below If Solution resolved Else Any Query ? Plaese Comment Below. Thank You.

Leave a Reply

Your email address will not be published. Required fields are marked *

close